Przyjazne użytkownikom polskie wsparcie phpBB 3.0

Twoja przeglądarka jest przestarzała i nie wspiera obecnych standardów WWW.
Zalecamy instalację najnowszej wersji jednej z przeglądarek, które poprawnie obsługują obecne standardy, np:

  • Arora
  • Chrome
  • Firefox
  • Opera
  • Safari

phpBB3 RC3 wydane!

phpBB3 RC3 wydane!

Postprzez LEW21 » 8 lip 2007, o 18:45 ·

8 lipca 2007 roku o godzinie 19:20 wydana została wersja Release Candidate 3 skryptu phpBB3!

Download

phpBB3 Release Candidate 3 (RC3) released - tłumaczenie
Acyd Burn napisał(a):Witamy,

Jesteśmy szczęśliwi, że możemy ogłosić dostępność wersji RC3 skryptu phpBB3. To jest trzeci kandydat do wydania, który zostanie zmieniont w wersję finalną jeżeli nie zostaną znalezione żadne błędy. Oczywiście może zostać wydanych więcej kandydatów do wydania.

Do kandydatów do wydania oferowane jest pełne wsparcie na naszym forum, pozwalamy na wgrywanie pakietów językowych, MODów i stylów. Będziemy wspierać tylko użytkowników posiadających czyste instalacje RC3 lub aktualizacje z starszych wersji RC. Wcześniejsze konwersje lub aktualizacje nie będą wspierane. Nadal zalecamy wstrzymanie się z instalacją phpBB3 do czasu wydania finalnej wersji - to przecież, zgodnie z nazwą, jest tylko kandydat do wydania.
Zauważ też że nalegamy żebyś zaaktualizował forum - wspieramy tylko najnowszą wersję. Raporty o błędach w starszych wersjach będą również zamykane jako że tylko najnowsza wersja jest wspierana.

Oto pełny log zmian od wersji RC1:

m

Przypominamy że nie będziemy wspierać tych rodzajów instalacji:
  • Aktualizacja z wersji beta phpBB3 do phpBB3 RC1 i nowszych wersji
  • Konwersja z phpBB 2.0.x do phpBB3 w wersji beta
  • Instalacja phpBB3 w wersji beta
Będziemy w pełni wspierać:
  • Aktualizacja z wersji RC phpBB3 do każdej nowszej wersji
  • Konwersja z phpBB 2.0.x do phpBB3 w wersji RC lub nowszej
  • Instalacja phpBB3 w wersji RC lub nowszej

Krótkie wyjaśnienie jak dokonać konwersji, instalacji lub aktualizacji znajduje się w pliku docs/INSTALL.html file, nie zapomnij o jego przeczytaniu. Jeżeli chcesz być całkowicie bezpieczny poczekaj na kolejne wydania phpBB3 zanim przekonwertujesz swoją instalację phpBB 2.0.x.

Minimalne Wymagania
phpBB3 ma kilka wymagań które muszą zostać spełnione zanim będziesz mógł je zainstalować i używać.
  • Serwer WWW lub konto hostingowe działające na dowolnym systemie operacyjnym wspierającym PHP
  • System bazy danych SQL - jeden z:
    • MySQL 3.23+ (MySQLi jest wspierane)
    • PostgreSQL 7.3+
    • SQLite 2.8.2+
    • Firebird 2.0+
    • MS SQL Server 2000+ (bezpośrednio lub przez ODBC)
    • Oracle
  • PHP 4.3.3+ (>=4.3.3, >4.4.x, >5.x.x, >6.0-dev (kompatybilna)) ze wsparciem dla bazy danych której chcesz użyć.
  • Funkcja PHP getimagesize() musi być odblokowana
  • Te moduły PHP nie są konieczne, ale umożliwią Ci korzystanie z dodatkowych funkcji.
    • wsparcie kompresji zlib
    • Wsparcie zdalnego FTP
    • Wsparcie XML
    • Wsparcie Imagemagick
    • Wsparcie GD
Wymagania zostaną automatycznie sprawdzone w czasie procesu instalacji.

Bezpieczeństwo
Problemy z bezpieczeństwem powinny być zgłaszane do naszego trakera bezpieczeństwa w zwykły sposób.

Dostępne pakiety
Jeżeli napotkasz problemy z automatyczną aktualizacją (biały ekran, timeouty itp) użyj do aktualizacji metody "tylko zmienione pliki" lub "patch".

W tym wydaniu dostępne są cztery pakiety.
  • Pełny pakiet
    Zawiera cały kod phpBB3 i angielskie pliki językowe.
  • Tylko zmienione pliki
    Zawiera tylko pliki zmienione od poprzednich wersji phpBB3. Zauważ że to archiwum zawiera pliki zmienione w każdej z poprzednich wersji.
  • Pliki patch
    Zawiera patch-kompatybilne patche od poprzednich wersji phpBB3.
  • Pakiet automatycznej aktualizacji
    Pakiet aktualizacji dla automatycznego aktualizatora zawierający zmiany między poprzednim wydaniem a tym wydaniem.

Wybierz pakiet, który najbardziej Ci pasuje.

Pamiętaj o przeczytaniu dokumentów INSTALL i README (znajdują się w folderze docs/) zanim zaczniesz instalację, aktualizację lub konwersję!

Download/Dokumentacja
Nie zapomnij zagłosować na nas na Sourceforge Community Choise Awards.

Have fun with the release,
the phpBB Teams.
Potrzebujesz pomocy? Napisz na forum zamiast wysyłać komuś prywatną wiadomość lub pisać do kogoś przez jakiś komunikator.
Avatar użytkownika

LEW21

Papa SmerfPosty: 3196Dołączył(a): 18 cze 2006, o 12:17Lokalizacja: Warszawa

Re: phpBB3 RC3 wydane!

Postprzez Mike_PL » 8 lip 2007, o 18:58 ·

Czyli jeśli mam RC2 i chce uaktualnić do RC3 to ściągam wersje "Changed Files Only" i normalnie nadpisuje wszystkie pliki? Nie trzeba wykonywać żadnego zapytania SQL?

Mike_PL

Posty: 21Dołączył(a): 23 maja 2007, o 19:25

Re: phpBB3 RC3 wydane!

Postprzez LEW21 » 8 lip 2007, o 19:10 ·

Nie, ściągasz wersję "Pakiet automatycznej aktualizacji" ("Automatic Update Package") i postępujesz zgodnie z instrukcjami w pliku docs/INSTALL.html.
Potrzebujesz pomocy? Napisz na forum zamiast wysyłać komuś prywatną wiadomość lub pisać do kogoś przez jakiś komunikator.
Avatar użytkownika

LEW21

Papa SmerfPosty: 3196Dołączył(a): 18 cze 2006, o 12:17Lokalizacja: Warszawa

Re: phpBB3 RC3 wydane!

Postprzez bargain4uuu » 8 lip 2007, o 20:51 ·

A jak ja mam jeszcze Rc1 to moge przejsc odrazu do rc3 ????

bargain4uuu

Posty: 79Dołączył(a): 18 mar 2007, o 21:59

Re: phpBB3 RC3 wydane!

Postprzez Haspet » 8 lip 2007, o 20:56 ·

Nie, ściągasz wersję "Pakiet automatycznej aktualizacji" ("Automatic Update Package") i postępujesz zgodnie z instrukcjami w pliku docs/INSTALL.html.

No własnie, ja miałem problem z plikiem /includes/funcions_module.php nie pamiętam dokładnie błędu po aktualizacji ale brzmiał on mniejwięcej tak:
funcions_module.php disable for security reasons, było jeszcze jeden błąd, a po tym cała strona w krzakach, nie przyglądałem się błędowi, tylko wgrałem starszy plik z kopi zapasowej którą zrobiłem przed aktualizacją. Inaczej nie mogłem wejsc do PA.
P.S Mogę dostać na PW tą szybką odpowiedź ? Bo ja mam na swym forum, ale strasznie... ekhm... kiepską.

Haspet

Posty: 7Dołączył(a): 13 lis 2006, o 17:39

Re: phpBB3 RC3 wydane!

Postprzez Bananikus » 8 lip 2007, o 21:01 ·

kuku.pl - nie, musisz najpierw zaktualizować do RC2 a dopiero potem do RC3.

Lew: Lepiej byś changeloga przetłumaczył, a nie jakieś listy, które były tu 10 razy i i tak nikt ich nie czyta :p
Obrazek
Avatar użytkownika

Bananikus

Posty: 276Dołączył(a): 24 lis 2006, o 17:00

Re: phpBB3 RC3 wydane!

Postprzez LEW21 » 8 lip 2007, o 22:36 ·

@Bananikus: Jakie changelogi jak nic się nie zmienia oprócz zamykania bugów A to jest dużo prościej - kopiuję z poprzedniego posta, zamieniam RC2 na RC3 i gotowe (żartuję, to nie takie proste - zawsze są jakieś zmiany kosmetyczne czy usunięcie/dodanie akapitu... ale tak czy siak to prostsze niż jakieś tam changelogi )

@Haspet: W takim poczekaj na mój konwerter. A co do szybkiej odpowiedzi - używamy Quick Posting MODa 2.0 (czyli Last stable version). Instalacji bety QP3 nie zalecam - jest mocno zbugowana, a wiele jej części zmieni się totalnie w drugiej becie.
Potrzebujesz pomocy? Napisz na forum zamiast wysyłać komuś prywatną wiadomość lub pisać do kogoś przez jakiś komunikator.
Avatar użytkownika

LEW21

Papa SmerfPosty: 3196Dołączył(a): 18 cze 2006, o 12:17Lokalizacja: Warszawa

Re: phpBB3 RC3 wydane!

Postprzez sibo » 8 lip 2007, o 23:14 ·

Aktualizacja przrbiegła bez przeszkód
Pozdrawiam
Patriae Fidelis
Avatar użytkownika

sibo

VeteranPosty: 344Dołączył(a): 21 mar 2007, o 20:31Lokalizacja: Poland, Poznań

Re: phpBB3 RC3 wydane!

Postprzez mateofi » 9 lip 2007, o 16:57 ·

Witam,

Mam problem. Aby zaktualizować forum z RC1 do RC3, trzeba najpierw z RC1 do RC2. Przy aktualizacji za pomocą "Automatic Update Package" wyskakuje mi komunikat:

UWAGA! Pliki aktualizacyjne nie są aktualne. Znalezione pliki aktualizują phpBB z wersji 3.0.RC1 do wersji 3.0.RC2, ale najnowsza wersja phpBB to 3.0.RC3.


I nic więcej. Nie mogę aktualizować.
Avatar użytkownika

mateofi

VeteranPosty: 410Dołączył(a): 23 sty 2007, o 09:32

Re: phpBB3 RC3 wydane!

Postprzez sibo » 9 lip 2007, o 18:16 ·

Wgraj na serwer najnowsze pliki i wszystko pójdzie bez problemu.
Oczywiście zrób kopie bezpieczeństwa by nie trzeba było potem sobie pluć w twarz jak coś nie wyjdzie
Patriae Fidelis
Avatar użytkownika

sibo

VeteranPosty: 344Dołączył(a): 21 mar 2007, o 20:31Lokalizacja: Poland, Poznań

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość

Zaloguj  •  Zarejestruj