Przyjazne użytkownikom polskie wsparcie phpBB 3.0

Twoja przeglądarka jest przestarzała i nie wspiera obecnych standardów WWW.
Zalecamy instalację najnowszej wersji jednej z przeglądarek, które poprawnie obsługują obecne standardy, np:

  • Arora
  • Chrome
  • Firefox
  • Opera
  • Safari

phpBB 3.0.8 wydane.

phpBB 3.0.8 wydane.

Postprzez LEW21 » 21 lis 2010, o 00:35 ·

Wczoraj, o 18:21 wydana została nowa wersja phpBB, 3.0.8, o nazwie kodowej "Cierpliwość jest cnotą". Łata ona wiele błędów i poprawia użyteczność oraz wydajność. Niestety wykryliśmy też problem z bezpieczeństwem w poprzedniej wersji dotyczący forów z włączonym BBCodem flash - domyślnie jest wyłączony. Na przeglądarkach WebKitowych, takich jak Safari i Chrome, oraz Operze, BBCode flash może zostać użyty do uruchomienia kodu JS w celu wykorzystania błędu XSS (cross site scripting).

Aby naprawić ten problem w 3.0.7, proszę przejść do linii 354 w includes/message_parser.php, i zaraz przed

Kod: Zaznacz cały

          // Apply the same size checks on flash files as on images

wstawić:

Kod: Zaznacz cały

          $in = str_replace(' ', '%20', $in);

          // Make sure $in is a URL.
          if (!preg_match('#^' . get_preg_expression('url') . '$#i', $in) &&
             !preg_match('#^' . get_preg_expression('www_url') . '$#i', $in))
          {
             return '[flash=' . $width . ',' . $height . ']' . $in . '[/flash]';
          }


Nie rozwiąże to problemu w już istniejących postach. Aby umożliwić przeskanowanie forum pod względem szkodliwych postów stworzyliśmy skrypt skanujący. Po prostu umieść go w głównym katalogu phpBB i otwórz jego adres w przeglądarce internetowej. Nowa wersja Support Toolkit zawierająca ten skrypt oraz narzędzie służące do ponownego parsowania konkretnych postów zostanie wydana niedługo. Poinformujemy Was o tym.

Wydanie to naprawia również problem z pluginem recaptchy, który mógł pomóc spamerom ominać potwierdzenie wizualne w niektórych przypadkach. Podziękowania za zauważenie kilku błędów i dobre ocenienie bezpieczeństwa phpBB należą się Evilzone.org.

Koniec tłumaczenia oficjalnego artykułu

Oczywiście zalecamy aktualizację, poprzednia wersja phpBB3 - 3.0.7 - będzie wspierana na naszym forum do 6 grudnia.

Pobierz phpBB3+spolszczenie

Ogłoszenie o wydaniu
Download phpBB.com
Zaktualizowane spolszczenie r182
Potrzebujesz pomocy? Napisz na forum zamiast wysyłać komuś prywatną wiadomość lub pisać do kogoś przez jakiś komunikator.
Avatar użytkownika

LEW21

Papa SmerfPosty: 3196Dołączył(a): 18 cze 2006, o 12:17Lokalizacja: Warszawa

Re: phpBB 3.0.8 wydane.

Postprzez Elian » 23 lis 2010, o 14:20 ·

Jestem nowy jeżeli chodzi o phpBB3 i mam pytanie dotyczące rozszerzania mojego forum do wersji 3.0.8
Czy modyfikacje zainstalowane pod 3.0.7 będą działać także po rozszerzeniu do 3.0.8?
Chodzi mi konkretnie o "Custom BBCode only for MOD" oraz "Board3 Portal"

PS
Jeżeli pytanie nie powinno się tu znaleźć, to proszę przenieść do odpowiedniego miejsca.

Elian

NowyPosty: 4Dołączył(a): 22 lis 2010, o 19:35

Re: phpBB 3.0.8 wydane.

Postprzez pawelooss » 23 lis 2010, o 14:58 ·

Nikt Ci nie da gwarancji, że nie zmieniły się jakieś newralgiczne linie skryptu, ale w większości przypadków zainstalujesz bez większych problemów.
Avatar użytkownika

pawelooss

LeniuszekPosty: 366Dołączył(a): 14 sie 2009, o 19:01

Re: phpBB 3.0.8 wydane.

Postprzez lukasamd » 23 lis 2010, o 15:46 ·

Przy próbie pobrania spolszczenia:
550 Failed to change directory.

lukasamd

Posty: 67Dołączył(a): 9 sty 2008, o 19:25

Re: phpBB 3.0.8 wydane.

Postprzez GrassPL » 25 lis 2010, o 17:15 ·

Po aktualizacji padł mi dział Arcade a dokładniej możliwość samego grania przez pojawiający się komunikat o konieczności instalacji najnowszej wersji Adobe Flash Player. Mimo instalacji najnowszej wersji - komunikat jest ten sam.
Co począć w tej sytuacji? Screen niżej:

arcade.jpg

Screen błędu



W IE widzę informację o błędzie "brak definicji swfobject" ?
Avatar użytkownika

GrassPL

Posty: 149Dołączył(a): 30 gru 2008, o 13:39

Re: phpBB 3.0.8 wydane.

Postprzez napus » 25 lis 2010, o 19:57 ·

Zainstaluj najnowszą wersję arcade: http://www.jeffrusso.net/forum/viewtopi ... =20&t=1328
Avatar użytkownika

napus

VeteranPosty: 7662Dołączył(a): 11 mar 2009, o 20:16Lokalizacja: Rzeszów

Re: phpBB 3.0.8 wydane.

Postprzez GrassPL » 25 lis 2010, o 20:20 ·

Dzięki napus. Jak zwykle pomogłeś Obrazek
Avatar użytkownika

GrassPL

Posty: 149Dołączył(a): 30 gru 2008, o 13:39

Re: phpBB 3.0.8 wydane.

Postprzez Fragles » 27 lis 2010, o 12:52 ·

Spisałem kilka błędów które wyskoczyły mi podczac aktualizacji, zebrałem je i podałem rozwiązanie.

1. Podczas aktualizacji bazy danych otrzymujesz komunikat:

Kod: Zaznacz cały

Fatal error: [...]/includes/db/dbal.php on line 694


Otwórz plik config.php i włącz debug mode:

Kod: Zaznacz cały

@define('PHPBB_INSTALLED', true);
@define('DEBUG', true);
@define('DEBUG_EXTRA', true);


Zoabczysz treść błędów.

2. Po wykonaniu powyższej instrukcji otrzymujesz:

Kod: Zaznacz cały

UPDATE phpbb_extension_groups SET group_name = 'ARCHIVES' WHERE group_name = 'Archives'
.
UPDATE phpbb_extension_groups SET group_name = 'DOCUMENTS' WHERE group_name = 'Documents'
.
UPDATE phpbb_extension_groups SET group_name = 'DOWNLOADABLE_FILES' WHERE group_name = 'Downloadable Files'
.
UPDATE phpbb_extension_groups SET group_name = 'FLASH_FILES' WHERE group_name = 'Flash Files'
.
UPDATE phpbb_extension_groups SET group_name = 'IMAGES' WHERE group_name = 'Images'
.
UPDATE phpbb_extension_groups SET group_name = 'PLAIN_TEXT' WHERE group_name = 'Plain Text'
.
UPDATE phpbb_extension_groups SET group_name = 'QUICKTIME_MEDIA' WHERE group_name = 'Quicktime Media'
.
UPDATE phpbb_extension_groups SET group_name = 'REAL_MEDIA' WHERE group_name = 'Real Media'
.
UPDATE phpbb_extension_groups SET group_name = 'WINDOWS_MEDIA' WHERE group_name = 'Windows Media'
.
UPDATE phpbb_modules SET module_auth = 'cfg_allow_avatar && (cfg_allow_avatar_local || cfg_allow_avatar_remote || cfg_allow_avatar_upload || cfg_allow_avatar_remote_upload)' WHERE module_class = 'ucp' AND module_basename = 'profile' AND module_mode = 'avatar'


Otwórz plik includes/db/dbal.php i znajdź:

Kod: Zaznacz cały

         if (strlen($message) > 1024)
         {
            // We need to define $msg_long_text here to circumvent text stripping.
            global $msg_long_text;
            $msg_long_text = $message;

            trigger_error(false, E_USER_ERROR);
         }


Zamień na:

Kod: Zaznacz cały

         if (strlen($message) > 1024)
         {
            // We need to define $msg_long_text here to circumvent text stripping.
            global $msg_long_text;
            $msg_long_text = $message;
            die($msg_long_text);
            trigger_error(false, E_USER_ERROR);
         }


Teraz powinieneś zobaczyć całą treść błędów np.

Column 'user_points' cannot be null [1048]

Pomogła edycja pliku includes/functions_user.php:

Kod: Zaznacz cały

      'user_points'         => $register_points,


Zmienić na:

Kod: Zaznacz cały

      'user_points'         => 0,


Jest to prowizoryczne rozwiazanie więc tuż po aktualizacji bazy przywrócić poprzedni config.php, poprzedni includes/db/dbal.php oraz poprzedni includes/functions_user.php ( lub odwrócić instrukcje ;) )

Następnie wszystko już przebiegało bez zarzutu.
Avatar użytkownika

Fragles

Posty: 229Dołączył(a): 30 lis 2009, o 19:15Lokalizacja: Poznań

Re: phpBB 3.0.8 wydane.

Postprzez salamonpl » 30 lis 2010, o 10:20 ·

Witajcie
W nocy zaczęłam instalować, wszystko szło gładko aż do tworzenia tabel. Zamiast się tworzyć, pokazała się pusta strona. Odczekałam jakiś czas i zaczęłam od początku - utknęłam w tym samym miejscu, na dodatek instalator kazał mi zmienić nazwy prefiksów(?) tabel z phpbb_ na inną. Zmieniłam na phpbb2, ale znów wszystko się zatrzymało. Zgłupiałam.
Odświeżyłam stronę i zobaczyłam takie coś:

http://img149.imageshack.us/img149/882/errorpf.jpg

W phpmyAdmin widzę, że powstały nowe tabele i mam pytanie, czy jeśli je usunę, to niczego bardziej nie spieprzę?
Pomocy!

salamonpl

Posty: 19Dołączył(a): 16 sty 2008, o 03:21

Re: phpBB 3.0.8 wydane.

Postprzez salamonpl » 30 lis 2010, o 14:34 ·

Jakoś sobie poradziłam, ale po instalacji mam zamiast forum taki napis:

Language file ./language/pl/common.php couldn't be opened.

salamonpl

Posty: 19Dołączył(a): 16 sty 2008, o 03:21

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość

Zaloguj  •  Zarejestruj

cron