Przyjazne użytkownikom polskie wsparcie phpBB 3.0

Twoja przeglądarka jest przestarzała i nie wspiera obecnych standardów WWW.
Zalecamy instalację najnowszej wersji jednej z przeglądarek, które poprawnie obsługują obecne standardy, np:

  • Arora
  • Chrome
  • Firefox
  • Opera
  • Safari

Phpbb 3.1.2

Regulamin działu

Zabrania się zakładania wątków dotyczących problemów z phpBB3.

Phpbb 3.1.2

Postprzez drooid » 19 gru 2014, o 22:07 ·

Ktoś się już przesiadł na tę wersję?

Zrobiłem właśnie przejście z 3.0.11 na 3.1.2. Działa, ale... ta wersja jakby jakaś niedorobiona jest :(
W templatkach są zmienne nie deklarowane w php. Nie są przez to wyświetlane niektóre dane, np. informacji o użytkowniku.
W memberlist_view.html mam ostatnią wizytę na forum nieokreśloną. Niby powinna zostać przekazana przez VISITED, ale VISITED nie jest zdefiniowane w memberlist.php. Są tam inne zmienne, nie używane w szablonie strony.

Czy macie podobnie, czy mam jakąś niedorobioną wersję?
phpbb3: 3.1.2 | spolszczenie: phpbb.pl | czysta instalacja od 3.1.2 | aktualizowane: nie | nie konwertowane | mody: Automod | style: subsilver2 | serwer: płatny | php: 5.5.16 | mysql: 5.5.39
Avatar użytkownika

drooid

GapikPosty: 577Dołączył(a): 14 maja 2008, o 08:26Lokalizacja: Łódź

Re: Phpbb 3.1.2

Postprzez Hector » 19 gru 2014, o 22:11 ·

Moze styl trzeba aktualizować
Avatar użytkownika

Hector

OsiłekPosty: 1623Dołączył(a): 19 paź 2011, o 11:36

Re: Phpbb 3.1.2

Postprzez drooid » 19 gru 2014, o 22:17 ·

Pobrałem skądś subsilver2, niby do 3.1.2. Może masz rację, może to tylko zmyła a styl stary. Obadam to jeszcze bo teraz nawet nie pamiętam skąd to zassałem a phpbb.com zdechło.
phpbb3: 3.1.2 | spolszczenie: phpbb.pl | czysta instalacja od 3.1.2 | aktualizowane: nie | nie konwertowane | mody: Automod | style: subsilver2 | serwer: płatny | php: 5.5.16 | mysql: 5.5.39
Avatar użytkownika

drooid

GapikPosty: 577Dołączył(a): 14 maja 2008, o 08:26Lokalizacja: Łódź

Re: Phpbb 3.1.2

Postprzez drooid » 19 gru 2014, o 22:38 ·

Faktycznie dopiero teraz znalazłem paczkę stylu do 3.1.2. Wygląda jakby ciut lepiej.
Zobaczymy co dalej się zadzieje, bo wszystkie mody muszę przerabiać pod tę wersję :(
phpbb3: 3.1.2 | spolszczenie: phpbb.pl | czysta instalacja od 3.1.2 | aktualizowane: nie | nie konwertowane | mody: Automod | style: subsilver2 | serwer: płatny | php: 5.5.16 | mysql: 5.5.39
Avatar użytkownika

drooid

GapikPosty: 577Dołączył(a): 14 maja 2008, o 08:26Lokalizacja: Łódź

Re: Phpbb 3.1.2

Postprzez drooid » 20 gru 2014, o 18:32 ·

W PA-Rozszerzenia wywalany jest błąd:

Kod: Zaznacz cały

SQL ERROR [ mysql4 ]

Table 'forgenpl_forum.ANNOUNCEMENTS_CENTRE_TABLE' doesn't exist [1146]

SQL

SELECT * FROM ANNOUNCEMENTS_CENTRE_TABLE

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 181
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysql->sql_query()

FILE: [ROOT]/includes/acp/acp_announcements_centre.php
LINE: 114
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 674
CALL: acp_announcements_centre->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()

Jest to jakaś pozostałość po acp_announcement_center, którego nie dodawałem po aktualizacji a przed wszystkie pliki przecież zostały usunięte. Jak się tego pozbyć?
phpbb3: 3.1.2 | spolszczenie: phpbb.pl | czysta instalacja od 3.1.2 | aktualizowane: nie | nie konwertowane | mody: Automod | style: subsilver2 | serwer: płatny | php: 5.5.16 | mysql: 5.5.39
Avatar użytkownika

drooid

GapikPosty: 577Dołączył(a): 14 maja 2008, o 08:26Lokalizacja: Łódź

Re: Phpbb 3.1.2

Postprzez all4phone » 20 gru 2014, o 22:22 ·

W pliku includes/acp/acp_announcements_centre.php są zapytania do tabeli ANNOUNCEMENTS_CENTRE_TABLE.
To samo dotyczy pliku functions_announcements.php
Avatar użytkownika

all4phone

Posty: 177Dołączył(a): 5 wrz 2011, o 13:22

Re: Phpbb 3.1.2

Postprzez drooid » 21 gru 2014, o 11:51 ·

Poradziłem sobie chyba.
Instalacja 3.1.2 zassała do bazy danych modules stare mody, choć fizycznie zostały usunięte. Zrobiła to na podstawie pozostawionych tabel w bazie? Nie wiem.
Usunąłem z tabeli ręcznie wpisy wypluwające błędy jak wyżej i sytuacja się poprawiła, tylko że... zniknęła mi zakładka Rozszerzenia :o
Nie wiem teraz jak dodać rozszerzenie (ext). Czy zakładka pojawi się po wgraniu dowolnego moda Automodem?

Kolejna niedogodność to brak powiadomień mailem o rejestracji nowego usera. Powiadomienia o nowych postach dochodzą, a te aktywacyjne nie!
phpbb3: 3.1.2 | spolszczenie: phpbb.pl | czysta instalacja od 3.1.2 | aktualizowane: nie | nie konwertowane | mody: Automod | style: subsilver2 | serwer: płatny | php: 5.5.16 | mysql: 5.5.39
Avatar użytkownika

drooid

GapikPosty: 577Dołączył(a): 14 maja 2008, o 08:26Lokalizacja: Łódź

Re: Phpbb 3.1.2

Postprzez Hector » 21 gru 2014, o 12:12 ·

[quote="drooid"] zniknęła mi zakładka Rozszerzenia :o
Nie wiem teraz jak dodać rozszerzenie (ext). Czy zakładka pojawi się po wgraniu dowolnego moda Automodem?
/quote]
A nie można dodać jak moduł w w wersji 3.0?

PS.
z 3.1 jeszcze się nie witałem :)
Avatar użytkownika

Hector

OsiłekPosty: 1623Dołączył(a): 19 paź 2011, o 11:36

Re: Phpbb 3.1.2

Postprzez drooid » 21 gru 2014, o 12:41 ·

Hector napisał(a):A nie można dodać jak moduł w w wersji 3.0?

Właściwie nie wiem. Nie miałem w 3.0 Automoda i wszystko co dodawałem, dodawałem ręcznie. Poza tym sam robiłem trochę modyfikacji w kodzie.
Teraz, jedyną modyfikacją zainstalowaną na czysty 3.1.2 jest Automod, który poprzednich modów dla 3.0 mi nie instaluje. Wiem, że można je spokojnie przerobić. Automod czyta plik instalacyjny xml i na jego podstawie dokonuje zmian. Wystarczy edycja xml i wskazanie mu innych punktów zmian, ale to dla mnie za żmudne. Przynajmniej na chwilę obecną kiedy ratuję co się da, a co się posypało po przesiadce (ikony, guziki, ostatnie tematy, szablony dla nowych postów w wybranych działach, itp.)
Ręczne modyfikacje kodu (np. dopisanie STS support ticket system - z małymi zmianami) nie zmieniają niczego w zakładkach PA, Rozszerzeniach i Automodzie.
phpbb3: 3.1.2 | spolszczenie: phpbb.pl | czysta instalacja od 3.1.2 | aktualizowane: nie | nie konwertowane | mody: Automod | style: subsilver2 | serwer: płatny | php: 5.5.16 | mysql: 5.5.39
Avatar użytkownika

drooid

GapikPosty: 577Dołączył(a): 14 maja 2008, o 08:26Lokalizacja: Łódź

Re: Phpbb 3.1.2

Postprzez all4phone » 21 gru 2014, o 19:47 ·

Z tego co wiem to nie ma Automoda dla wersji 3.1.2 ale mogę się mylić.

System->Zarządzanie Modułami->Panel Administracji->Rozszerzenia
Avatar użytkownika

all4phone

Posty: 177Dołączył(a): 5 wrz 2011, o 13:22

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość

Zaloguj  •  Zarejestruj